Authress - Authress Development Connections "invalid_redirect" specified – Incident details

All systems operational

Authress Development Connections "invalid_redirect" specified

Resolved
Degraded performance
Started 7 months agoLasted 16 minutes

Affected

Login & Authentication API

Operational from 9:25 PM to 9:40 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. A change has been rolled out to all Authress accounts to revert the problematic functionality and users should again be able to log in at this time.

    The Authress Development Credentials are available for accounts to easily get up and running during the early integration with Authress. As usage matures, customers are urged to migrate from using these development credentials to ones owned by Authress Customers.

    Authress Development Credentials should not be used in production environments as they are unstable and can be impacted by both the Authress Development Team as well as the provider they are being used with. If you are using Authress provided development credentials with any of your connections and are looking to move to using Customer provided credentials but are unsure how, the instructions for each of the connections are available in the Authress KB: https://authress.io/knowledge-base/docs/authentication/connecting-providers-idp

    Or reach out to the Authress Development team via an Authress support ticket.

  • Identified
    Identified

    Identity Provider connections configured using the Authress development credentials prevented users from logging in with this connections.

    A configuration change to improve the ability to better manage providers that used non-compliant OAuth interfaces, prevented the Connections using Authress Development Credentials for being used during login.